Thema Datum  Von Nutzer Rating
Antwort
Rot Eigene Funktion im Makro mit Überladung eines Bereichs
18.01.2015 17:40:00 -nin
NotSolved
19.01.2015 01:25:44 Gast79796
NotSolved

Ansicht des Beitrags:
Von:
-nin
Datum:
18.01.2015 17:40:00
Views:
906
Rating: Antwort:
  Ja
Thema:
Eigene Funktion im Makro mit Überladung eines Bereichs
Guten Abend, ich versuche grade eine eigene Excel Funktion zum Ein-/Ausblenden von Zeilen zu programmieren. Diese möchte ich in einer WENN-Abfrage verwenden. Ich habe im Makro folgendes programmiert: Public Function Ausblenden(Zeile As Range) Range(Zeile).EntireRow.Hidden = True End Fnction Meine WENN-Abfrage sieht nun einfach so aus: =WENN(A1="x";Ausblenden(2:2);Ausblenden(3:3)) Wenn ich dies nun aufbaue, Erhalte ich den Wert-Fehler. Ich vermute mal, dass das Format der Überladung der Funktion falsch ist. Kann mir hier jemand auf die Sprünge helfen? Besten Dank, -nin

Ihre Antwort
  • Bitte beschreiben Sie Ihr Problem möglichst genau und ausführlich
  • Codeschnipsel am besten über den Code-Button im Text-Editor einfügen
  • Die Angabe der Emailadresse ist freiwillig und wird nur verwendet, um Sie bei Antworten auf Ihren Beitrag zu benachrichtigen
  • Bitte markieren Sie Ihre Anfrage als erledigt wenn Ihnen geholfen wurde
Thema: Name: Email:

 
 

Thema Datum  Von Nutzer Rating
Antwort
Rot Eigene Funktion im Makro mit Überladung eines Bereichs
18.01.2015 17:40:00 -nin
NotSolved
19.01.2015 01:25:44 Gast79796
NotSolved